docker-compose up 报错

存档自 BrainFrame 论坛。发布于 2020年4月7日。 11 条回复 · 2569 次浏览 由英文原帖翻译成中文。 阅读原文

AOTU support

我运行“docker-compose up”命令时,显示

image,然后我的 BrainFrame 客户端无法打开。
AOTU support

你好 Shao,感谢你反馈这个错误。

1. 发送日志

能否运行下面的命令:

docker-compose logs > logs.txt

然后把结果上传到论坛?

2. 也许是算法胶囊的问题

第一步,尝试在不加载任何算法胶囊的情况下运行 brainframe 服务端。检查 capsules/ 目录,确保里面没有任何文件。

然后重启 BrainFrame 服务端:

docker-compose down && docker-compose up

3. 如果仍然失败,删除数据库配置

完成上面的步骤后,能否试试下面的操作:

sudo mv volumes volumes_bak

然后运行:

docker-compose down && docker-compose up

如果仍然失败,也请把这次失败的日志发给我们。

AOTU support

日志在这里:logs.txt (121.1 KB)

AOTU support

这些日志看起来没有问题。删除 volumes 目录之后,BrainFrame 需要更长时间启动,因为数据库需要重新初始化。

AOTU support

我等了很久,客户端还是打不开,volumes 文件夹下的 mysql 文件夹里似乎也没有新增文件

image
AOTU support

我又看了一遍,发现最初阅读时漏掉了一条错误日志。

proxy_1         | 2020/04/07 06:44:11 [emerg] 1#1: host not found in upstream "api" in /etc/nginx/nginx.conf:28
proxy_1         | nginx: [emerg] host not found in upstream "api" in /etc/nginx/nginx.conf:28

看起来 BrainFrame 已经正常启动,但我们的 HTTP 代理在与它通信时出现了问题。能否把你的 docker-compose.yml 和(如果创建了的话).env 文件发给我?

AOTU support

谢谢你的回复。这是
docker-compose.yml (2.4 KB)。我没有创建 .env 文件

AOTU support

好的,你的 docker-compose.yml 看起来一切正常。我们来检查一下是否一切都在按预期运行。请运行 docker container ls 并把结果发给我们。

AOTU support

结果如下

image
AOTU support

好的,看起来数据库现在又启动不了了。能否用 docker-compose logs > logs.txt 把最新的日志发给我?

AOTU support

这是 logs.txt (33.2 KB)

AOTU support

给看到这些错误信息的其他人:BrainFrame 第一次启动时,或者 volumes 目录被删除之后,数据库会经历一个初始化过程。在较慢的硬盘上,这个过程可能需要相当长的时间。我们得出的结论是,数据库系统很可能在初始化过程中被中断,导致数据损坏。我们的解决办法是再次删除 volumes 目录,让它重新初始化。

补充:这些是让我判断数据库已损坏的日志。

database_1      | 2020-04-10T07:57:53.440673Z 1 [ERROR] [MY-011096] [Server] No data dictionary version number found.
database_1      | 2020-04-10T07:57:53.441118Z 0 [ERROR] [MY-010020] [Server] Data Dictionary initialization failed.
database_1      | 2020-04-10T07:57:53.441502Z 0 [ERROR] [MY-010119] [Server] Aborting
© 2026 Aotu 版权所有 · 网站隐私声明
Built on 2026-10-10 00:24:09 UTC