服务端安装错误:无法启动 database 服务

存档自 BrainFrame 论坛。发布于 2020年7月2日。 3 条回复 · 642 次浏览 由英文原帖翻译成中文。 阅读原文

AOTU support

你好,
我在安装 Brainframe 服务端时遇到了错误。启动服务端出了问题,所以我决定重新安装服务端,但又遇到了新问题。
下面是我的错误信息。

ERROR: for database Cannot start service database: driver failed programming external connectivity on endpoint brainframe_database_1 (a016ba5100958c2650aa9912f28594b45d1a7bf250d3c8523bb96ed42f1ad172): Error starting userland proxy: listen tcp 0.0.0.0:5432: bind: address already in use
ERROR: Encountered errors while bringing up the project.

谢谢。

AOTU support

BrainFrame 的数据库(Postgres)使用 5432 端口,看起来你可能有其他应用占用了这个端口。可以用下面的命令查看是哪个应用在使用该端口:

sudo lsof -i :5432

试着停止那个应用,然后重启 BrainFrame。如果你想让那个应用继续运行,可以在 docker-compose.yml 所在的目录中新建一个名为 .env 的文件,内容如下,以更改 BrainFrame 暴露数据库的端口:

DATABASE_PORT=5433

这些配置选项的说明见这里:https://aotu.ai/docs/advanced_usage/server_configuration/

AOTU support

非常感谢!这样非常好用!

AOTU support

很高兴听到这个消息!

© 2026 Aotu 版权所有 · 网站隐私声明
Built on 2026-10-10 00:24:09 UTC